Skip to main content

logoCorrectSize.png

Adaptive Insights LLC.

Manage OfficeConnect Report Files

Explains how to open, save, export, secure and copy OfficeConnect workbooks in Excel.

Open New OfficeConnect Workbooks

From the OfficeConnect tab, select File > New and select Blank Workbook.

The new workbook opens with initial default settings. You set the defaults now or update them through Workbook Properties in the OfficeConnect tab of the ribbon.

New OfficeConnect Workbook Prompt

To change default settings for a reporting workbook:

  1. Choose a date other than today's date as the report date.
  2. To make time elements absolute, clear the Make new time elements relative to report date option. See Set Report Dates.
  3. To only show zeros when you enter zeros on the worksheets, clear the Show zero in cells with no data option. Select this option to show zeros when:
    • No one enters a value on the corresponding worksheets.
    • The cross sections of data do not exist.
    • A planner or budgeter enters zero on the corresponding worksheets.

There are many more defaults in your report than those presented when you open a new workbook. Read about all Defaults Types and Precedence Rules.

Open Multiple Workbooks

To open additional workbooks, either open Excel and use the OfficeConnect ribbon or open an OfficeConnect file from your file management system. You can access all open OfficeConnect workbooks for the current instance. ​​​If you have access to more than one instance, each of these workbooks can be using data from different instances. 

Open additional workbooks:

  • Use the OfficeConnect ribbon in Excel.
  • Open an OfficeConnect file from your file management system. 
  • Close the current workbook and open a new one: click File > New or Existing. This closes the current workbook and opens a new one.

Between workbooks of the same instance:

  • Copy and paste elements and labels from one workbook to another. 
  • Use the Merge Worksheets option to copy over worksheets from another workbook.
  • You cannot copy and paste formulas between workbooks. 

If the workbooks have different instances, you can't copy, paste, or merge. See Connect to Different Instances.

Open Existing OfficeConnect Workbook

Find and open existing OfficeConnect workbooks: 

  • Click Recent from the OfficeConnect tab to see up to 25 of your most recently opened workbooks. Click the one you want to open.
  • Go to File > Open and browse to the location of the workbook.
  • Double-click an OfficeConnect workbook file (a file with an .xlsxai file extension) in Windows Explorer.

If the workbook displays blank cells, click Refresh to load the data.

Save OfficeConnect Workbooks

  1. Go to File > Save or File > Save As.

  2. Browse to the location where you want to store the workbook and change the file name if necessary.
  3. Click Save.
  4. When prompted, click Yes to hide the data as a security measure.  Placeholder text replaces the data.

Back up your OfficeConnect files. Microsoft Auto-Recovery does not always save the dynamic metadata.

Share Workbooks

You can share OfficeConnect workbooks: Click File > Share > Email. When recipients open the attached .xlsxai file, they'll log in to OfficeConnect so they can view and edit the report. 

You cannot share OfficeConnect workbooks through Review > Share Workbook. If you have added OfficeConnect worksheets to a shared workbook file, the OfficeConnect portion will not function properly to other editors and reviewers.

Export OfficeConnect Workbooks to Excel

You can save or export an OfficeConnect workbook as a regular Excel file. This is useful if you want to share the report with others who don’t have access to OfficeConnect.

When you export an OfficeConnect workbook to Excel, the file keeps the static labels and data in an .xlsxai file, but not the elements. Without the elements, you can't refresh the file with current data from Adaptive Insights. Instead, this file serves as a static snapshot of data.

The OfficeConnect .xlsxai workbook still exists with the Adaptive Insights elements.  You have two files — the static Excel workbook and the dynamic and connected OfficeConnect workbook.

To save an OfficeConnect workbook as a standard Excel file:

  1. Go to File OfficeConnect, and click Export Workbook

  2. Browse to the location where you want to store the Excel file, enter the file name, and then click Save.

Copy or Move Worksheets Between Workbooks

You can copy the contents and report element structure from one workbook into another.

If you have access to multiple instances, and the instances for each workbook are different, the merged worksheet uses the data of the target workbook instance. Check for discrepancies and missing elements in the merged worksheet. 

  1. Open the Workbook with the worksheets that you want to copy or move.
  2. Verify the following:
    • To add a new worksheet: the sheet name is unique between the two workbooks.
    • To replace a worksheet: the sheet name is the same between the two workbooks.
  3. Rename a worksheet if necessary:
    • Double click the sheet tab at the bottom of the screen and type the new name. Press Enter.
    • Right-click in the sheet tab and select Rename. Then type the new name and press Enter.
  4. Save and close the workbook and then open a new workbook.

  5. Go to File OfficeConnect, and click Merge Workbook.

    File menu for merging workbooks
     

  6. Browse to find the original .xlsxai workbook and click Open.

  7. Select the checkboxes next to the names of the worksheets you want to add to the target workbook and those you want to replace. You can only replace worksheets that have the same name.

  8. Click OK.

Update Elements in Multiple Workbooks 

You can update the Reporting pane on the left to reflect the latest elements across multiple workbooks in the same instance. 

From the OfficeConnect tab, locate the Connection group and select Update Elements.

  • Was this article helpful?