Skip to main content
Adaptive Insights
Knowledge and Support - Adaptive Insights

Error occurred while processing report with following error message

Question

One of my users receives an error message that reads "Error occurred while processing report with following error message: All segments on the horizontal axis must include version.  Please modify the report and retry."  What does this mean?  I don't get this error when I view the report and the report looks correct to me.

Report Error1.png

 

Answer

This error is likely appearing because the user receiving the error does not have access to at least one of the versions included on the report.  If you navigate to Modeling>Versions you can see the access settings for each version included on the sheet.  If you want the user to be able to see the report you will want to make sure the version is not set to "Hidden" for the user.  Once the user has access to every version on the report they should be able to load the report successfully.

 

Version folders also come into play here.  If the version is available to the user and they still get this error make sure the folder the version is located in is also available to the user.

 

Version Access.png