Skip to main content
Adaptive Insights
Knowledge and Support - Adaptive Insights

Manage OfficeConnect Report Files

Explains how to open, save, export, secure and copy OfficeConnect workbooks in Excel.

OfficeConnect for Excel workbook files have an .xlsxai file extension and use the Adaptive logo. You can have up to three separate workbooks open at once.

Open New OfficeConnect Workbooks

Start OfficeConnect for Excel from the Windows start menu and log in using your Adaptive Planning username and password. If you are already logged in to OfficeConnect, select File > New and click Blank Workbook

The New Workbook opens with initial default settings. You set the defaults now or update them through Workbook Properties in the OfficeConnect tab of the ribbon.

New OfficeConnect Workbook Prompt

  • Click the Report Date dropdown arrow to choose a date other than today's date.
  • Select Make new time elements relative to report date or clear it to make time elements absolute. See Set Report Dates.
  • Clear Show zero in cells with no data to only show zeros when zero has been entered on the corresponding sheet cell. Select Show zero in cells with no data if you want to show zeros when:
    • No one has entered a value on the corresponding sheet cell yet.
    • The cross sections of data do not exist.
    • A planner or budgeter entered zero on the corresponding sheet cell

There are many more defaults in your report than those presented when you open a new workbook. Read about all Defaults Types and Precedence Rules.

Open More than One Workbook

To open additional workbooks, you must either use the Windows Start menu to launch OfficeConnect for Excel or open an OfficeConnect file from your file management system. You can have up to three OfficeConnect workbooks open at once. 

  • Copy and paste elements and labels from one workbook to another. 
  • Use the Merge Worksheets option to copy over worksheets from another workbook.
  • Formulas cannot be copied and pasted between workbooks.

Open Existing OfficeConnect Workbook

Find and open existing OfficeConnect workbooks: 

  • Click Recent from the OfficeConnect tab to see up to 25 of your most recently opened workbooks. Click the one you want to open.
  • Go to File > Open and browse to the location of the workbook.
  • Double-click an OfficeConnect workbook file (a file with an .xlsxai file extension) in Windows Explorer.

If the workbook displays blank cells, click Refresh to load the data.

Save OfficeConnect Workbooks

  1. Go to File > Save or File > Save As.

  2. Browse to the location where you want to store the workbook and change the file name if necessary.
  3. Click Save.
  4. When prompted, click Yes to hide the data as a security measure.  Placeholder text replaces the data.

Share Workbooks

You can share OfficeConnect workbooks: Click File > Share > Email. When recipients open the attached .xlsxai file, they'll log in to OfficeConnect so they can view and edit the report. 

You cannot share OfficeConnect workbooks through Review > Share Workbook. If you have added OfficeConnect worksheets to a shared  workbook file, the OfficeConnect portion will not function properly to other editors and reviewers. To save your work and share it properly: 

  1. Save the OfficeConnect file with an .xlsx extension. 
  2. Change the Review settings:
    1. Click Review
    2. Click Share Workbook
    3. Uncheck Allow changes by more than one user at the same time... 
    4. Click OK.

      screen of review tab options to select
  3. Save the file with an .xlsxai extension. Send the workbook via email for others to review and edit, one at a time. 

 

Export OfficeConnect Workbooks to Excel

You can save, or export, an OfficeConnect workbook as a regular Excel file. This is useful if you want to share the report with others who don’t have access to OfficeConnect.

When you export an OfficeConnect workbook to Excel, the file keeps the static labels and data in an .xlsx file, but not the elements. Without the elements, you can't refresh the file with current data from the Adaptive Planning. Instead, this file serves as a static snapshot of data.

The OfficeConnect .xlsxai workbook still exists with the Adaptive Planning elements.  You have two files — the static Excel workbook and the dynamic and connected OfficeConnect workbook.

To save an OfficeConnect workbook as a standard Excel file:

  1. Go to File OfficeConnect, and click Export Workbook.

  2. Browse to the location where you want to store the Excel file, enter the file name, and then click Save.

Copy Worksheets Between Workbooks

Copy the contents of one OfficeConnect workbook, including element structure, into another workbook by using the Merge Workbook command.

  1. Open the Workbook with the worksheet you want copied.
  2. Verify the following:
    • To add a new worksheet: verify that the sheet name is unique between the two workbooks.
    • To replace a worksheet: verify that the sheet name is the same between the two workbooks.
  3. Rename a worksheet if necessary:
    • Double click the sheet tab at the bottom of the screen and type the new name. Press Enter.
    • Right-click in the sheet tab and select Rename. Then type the new name and press Enter.
  4. Save and close the workbook and then open a new workbook.

  5. Go to File OfficeConnect, and click Merge Workbook.

    File menu for merging workbooks
     

  6. Browse to find the original .xlsxai workbook and click Open.

  7. Select the checkboxes next to the names of the worksheets you want to add to the target workbook and those you want to replace. You can only replace worksheets that have the same name.

  8. Click OK.

  • Was this article helpful?